您好,欢迎来到网暖!

当前位置:网暖 » 站长资讯 » 建站基础 » 网络技术 » 文章详细 订阅RssFeed

VLAN trunk GVRP

来源:网络整理 浏览:257次 时间:2020-04-07

VLAN trunk GVRP
VLAN(virtual lan local area network)
虚拟局域网:是物理设备上连接的不受物理位置限制的用户的一个逻辑组
交换机分割冲突域(信号冲突的范围),不能分割广播域(同一网段),故valn分割广播域

帧格式引入:vlan tag(标签)四个字节,其中12bit作为标记,(4096个)。其他作为

功能:广播控制;安全性;带宽利用;延迟

VLAN的种类
基于端口划分的静态vlan(主流)
基于MAc地址划分的动态VLAN
VLAN  trunk  GVRP

参考:http://www.023wg.com/message/message/cd_feature_eth_vlan.html
VLAN  trunk  GVRP
PVID
Port vlan ID 表示端口所属的vlan,默认情况下是1

端口:
Access(访问)交换机和不同设备(除交换机外端口设置连接类型)
端口收到数据帧添加端口PVID的tag
端口发送数据帧剔除端口PVID的tag(如收到数据帧的TAG和端口的PVID不同则丢弃数据)

思科配置:
vlan 10
namecaiwu

interface FastEthernet0/1
switchport access vlan 10
switchport mode access (interface range fast Ethernet 0/0 0/3多端口同时配置)

interface FastEthernet0/2
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 20
switchport mode access

删除:先移除端口:no switchport access vlan 10
再删除vlan: no vlan 10(直接删除端口不会自动回到VLAN1内)

Tip:交换机的工作原理
1成表:学习,广播,转发,更新
2查表

华为:
vlan 10
description caiwu
vlan 20
description xingzheng
interface Ethernet0/0/1
port link-type access
port default vlan 10

port-group group-member g0/0/1 to g0/0/3同时配置端口

interface Ethernet0/0/2
port link-type access
port default vlan 10
#
interface Ethernet0/0/3
port link-type access
port default vlan 20
#
interface Ethernet0/0/4
port link-type access
port default vlan 20

批量生成vlan
Vlan Batch 10 to 20

删除:undo vlan 10(端口自动回归vlan1)

清除接口配置:clear configuration interface g0/0/1
Trunk:连接交换机
为了在同一个链路上同时传输多个vlan数据,用到此模式,该模式下,链路上的数据携带valn标签的
为链路数据打标签的方式、:

  1. isl:inter-switch link,思科私有协议
  2. 802.1q是公有标准,标签长度4字节
    交换机与交换机之间的链路叫做干道链路
    VLAN  trunk  GVRP
    配置:华为
    1创建vlan
    2终端设备交换机接口加入access
    3交换机接口加入trunk
    Port link-type trunk
    Port trunk allowpass vlan all
    思科:
  3. 先选择trunk协议(可选新设备没有了isl)
    Interface f0/1
    Switchport trunk encapsulated (封装)dot1q | isl
  4. 配置链路为trunk
  5. 检查show interface trunk
    检查show vlan brief(只能看到access口)

Hybrid(混合)
VLAN  trunk  GVRP

PVID:pord vlan id(用于对于进项的帧添加tag)
VLAN  trunk  GVRP
Hybrid的配置
创建vlan
vlan batch 10 20
配置端口
interface Ethernet0/0/1
port hybrid pvid vlan 10(pvid对于进入的没有tag的数据帧加上标签)
port hybrid untagged vlan 10
#
interface Ethernet0/0/2
port hybrid pvid vlan 20
port hybrid untagged vlan 20
interface GigabitEthernet0/0/1
port hybrid tagged vlan 10 20
验证
display port vlan
display vlan

GVRP(共有协议)
TIP:在交换网络中,必须确保所有的交换机上面的vlan信息是完全一致的,否则导致网络不通。
思科有个相同功能的VTP
GARP:generic attribute registration protocol
通用属性注册协议
主要用于建立一种属性传递扩散的机制

GVRP:GARP vlan registration protocol
用于注册和注销vlan属性
配置:
系统视图:开启GVRP
端口试图:开启GVRP(端口是trunk)
作用:
在不同交换机之间自动同步vlan信息
对于通过GVRP学习到的vlan,称之为动态vlan:
对于动态vlan
Access端口是不可以直接加入的;
Access端口只能加入到静态vlan
Trunk端口是自动加入的

推荐站点

  • 腾讯腾讯

    腾讯网(www.QQ.com)是中国浏览量最大的中文门户网站,是腾讯公司推出的集新闻信息、互动社区、娱乐产品和基础服务为一体的大型综合门户网站。腾讯网服务于全球华人用户,致力成为最具传播力和互动性,权威、主流、时尚的互联网媒体平台。通过强大的实时新闻和全面深入的信息资讯服务,为中国数以亿计的互联网用户提供富有创意的网上新生活。

    www.qq.com
  • 搜狐搜狐

    搜狐网是全球最大的中文门户网站,为用户提供24小时不间断的最新资讯,及搜索、邮件等网络服务。内容包括全球热点事件、突发新闻、时事评论、热播影视剧、体育赛事、行业动态、生活服务信息,以及论坛、博客、微博、我的搜狐等互动空间。

    www.sohu.com
  • 网易网易

    网易是中国领先的互联网技术公司,为用户提供免费邮箱、游戏、搜索引擎服务,开设新闻、娱乐、体育等30多个内容频道,及博客、视频、论坛等互动交流,网聚人的力量。

    www.163.com
  • 新浪新浪

    新浪网为全球用户24小时提供全面及时的中文资讯,内容覆盖国内外突发新闻事件、体坛赛事、娱乐时尚、产业资讯、实用信息等,设有新闻、体育、娱乐、财经、科技、房产、汽车等30多个内容频道,同时开设博客、视频、论坛等自由互动交流空间。

    www.sina.com.cn
  • 百度一下百度一下

    百度一下,你就知道

    www.baidu.com